package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?isU)([A-Z]{3})=(.*)+`)
var str = `ABC=TEXT 1 - HERE.. DEF=/TEXT 2: TEXT .. ZYX=TEXT 3 TEXT`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}