$re = '~([A-Z]{3})=(.*?)(?=[A-Z]{3}=|$)~im';
$str = 'ABC=TEXT 1 - HERE.. DEF=/TEXT 2: TEXT .. ZYX=TEXT 3 TEXT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);