re = /([A-Z]{3})=(.*?)(?=[A-Z]{3}=|$)/im
str = 'ABC=TEXT 1 - HERE.. DEF=/TEXT 2: TEXT .. ZYX=TEXT 3 TEXT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end