using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:https?://)?(?:www\.)\S+)";
string input = @"test http://www.bing.com test
test https://www.bing.com test
test www.bing.com test";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}