// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:https?://)?(?:www\.)\S+)").unwrap();
let string = "test http://www.bing.com test
test https://www.bing.com test
test www.bing.com test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}