$re = '/url\([\s+"\']?([^"\'>]+)[\s"\']?\)/siU';
$str = '@font-face{font-family:Icons;src:url(\'themes/default/assets/fonts/icons.eot\');src:url(themes/default/assets/fonts/icons.eot?#iefix) format(\'embedded-opentype\'),url(themes/default/assets/fonts/icons.woff2) format(\'woff2\'),url(themes/default/assets/fonts/icons.woff) format(\'woff\'),url(themes/default/assets/fonts/icons.ttf) format(\'truetype\'),url(themes/default/assets/fonts/icons.svg#icons) format(\'svg\');
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);