re = /url\([\s+"\']?([^"\'>]+)[\s"\']?\)/i
str = '@font-face{font-family:Icons;src:url(\'themes/default/assets/fonts/icons.eot\');src:url(themes/default/assets/fonts/icons.eot?#iefix) format(\'embedded-opentype\'),url(themes/default/assets/fonts/icons.woff2) format(\'woff2\'),url(themes/default/assets/fonts/icons.woff) format(\'woff\'),url(themes/default/assets/fonts/icons.ttf) format(\'truetype\'),url(themes/default/assets/fonts/icons.svg#icons) format(\'svg\');
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end