import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Born:.*in\\s+([^,]*),\\s+(.*?)(?=(?:\\s[A-Za-z]{2})?$)";
final String string = "Born: November 8, 1961 in Chicago, Illinois\n"
+ "Born: February 19, 1995 in Sombor, Serbia rs\n"
+ "Born: May 19, 1976 in Greenville, South Carolina us\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}