import re
regex = re.compile(r"Born:.*in\s+([^,]*),\s+(.*?)(?=(?:\s[A-Za-z]{2})?$)", flags=re.MULTILINE)
test_str = ("Born: November 8, 1961 in Chicago, Illinois\n"
"Born: February 19, 1995 in Sombor, Serbia rs\n"
"Born: May 19, 1976 in Greenville, South Carolina us\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")