package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(-?\d+|(\(.+\))|((\+?\-?\*?\/?)))`)
var str = `13 - 7*(14+2-1)/42`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}