$re = '/(-?\d+|(\(.+\))|((\+?\-?\*?\/?)))/';
$str = '13 - 7*(14+2-1)/42';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);