using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\(\d{4}\) ?\d{4}( |-)?\d{4}|^\d{4}( |-)?\d{3}( |-)?\d{4}";
string input = @"+0905312527889";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}