re = /^\(\d{4}\) ?\d{4}( |-)?\d{4}|^\d{4}( |-)?\d{3}( |-)?\d{4}/m
str = '+0905312527889'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end