using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d? ?)?(\d{3}|\(\d{3}\))[ -]?\d{3}[ -]?\d+$";
string input = @"1 (555) 555-5555
5555555555
1 555-555-5555
555-555-5555
1 555)555-5555
(6505552368)
10 (757) 622-7382
555)-555-5555";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}