re = /^(\d? ?)?(\d{3}|\(\d{3}\))[ -]?\d{3}[ -]?\d+$/m
str = '1 (555) 555-5555
5555555555
1 555-555-5555
555-555-5555
1 555)555-5555
(6505552368)
10 (757) 622-7382
555)-555-5555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end