#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)((?:https?(?:%3A%2F%2F|:\/\/))(?:www\.)?(?:\S+)(?:%2F|\/)(?:(?!\.(?:mp4|mkv|wmv|m4v|mov|avi|flv|webm|flac|mka|m4a|aac|ogg))[^\/])*\.(mp4|mkv|wmv|m4v|mov|avi|flv|webm|flac|mka|m4a|aac|ogg))(?!\/|\.[a-z]{1,3})"
Local $sString = "http://test.com/test.mkv" & @CRLF & _
"http://test.com/test/test.jpg.mkv" & @CRLF & _
"https://test.com/test.mkv?test=test" & @CRLF & _
"http%3A%2F%2Ftest.com%2Ftest.mkv%3Ftest%3Dtest" & @CRLF & _
"https%3A%2F%2Ftest.com%2Ftest.jpg.mkv%3Ftest%3Dtest.mkv" & @CRLF & _
"http://test.com/t est.mkv__some__random__string__http://test.com/test.mkv" & @CRLF & _
"The last example should match the two URLs but, not the __some__random__string__." & @CRLF & _
"" & @CRLF & _
"Some examples that should not be matched:" & @CRLF & _
"" & @CRLF & _
"http://test.com/test.mkv.jpg" & @CRLF & _
"http://test.com/test.mkv/test.jpg" & @CRLF & _
"https://test.com/test.mkv.jpg?test=test.mkv" & @CRLF & _
"http%3A%2F%2Ftest.com%2Ftest.mkv.jpg" & @CRLF & _
"https%3A%2F%2Ftest.com%2Ftest.mkv.jpg%3Ftest%3Dtest.mkv" & @CRLF & _
"http://test.com/t est.mkv__some__random__string__http://test.com/test.mkv.jpg" & @CRLF & _
"The last example should match only the first URL, before __some__random__string__"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")