# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:https?(?:%3A%2F%2F|:\/\/))(?:www\.)?(?:\S+)(?:%2F|\/)(?:(?!\.(?:mp4|mkv|wmv|m4v|mov|avi|flv|webm|flac|mka|m4a|aac|ogg))[^\/])*\.(mp4|mkv|wmv|m4v|mov|avi|flv|webm|flac|mka|m4a|aac|ogg))(?!\/|\.[a-z]{1,3})"
test_str = ("http://test.com/test.mkv\n"
"http://test.com/test/test.jpg.mkv\n"
"https://test.com/test.mkv?test=test\n"
"http%3A%2F%2Ftest.com%2Ftest.mkv%3Ftest%3Dtest\n"
"https%3A%2F%2Ftest.com%2Ftest.jpg.mkv%3Ftest%3Dtest.mkv\n"
"http://test.com/t est.mkv__some__random__string__http://test.com/test.mkv\n"
"The last example should match the two URLs but, not the __some__random__string__.\n\n"
"Some examples that should not be matched:\n\n"
"http://test.com/test.mkv.jpg\n"
"http://test.com/test.mkv/test.jpg\n"
"https://test.com/test.mkv.jpg?test=test.mkv\n"
"http%3A%2F%2Ftest.com%2Ftest.mkv.jpg\n"
"https%3A%2F%2Ftest.com%2Ftest.mkv.jpg%3Ftest%3Dtest.mkv\n"
"http://test.com/t est.mkv__some__random__string__http://test.com/test.mkv.jpg\n"
"The last example should match only the first URL, before __some__random__string__")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.