$re = '/(?<![A-z]-)^\bJohn\b$(?!-[A-z])/m';
$str = 'John Doe
John-Doe
Doe John
Doe-John
John
Doe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);