re = /(?<![A-z]-)^\bJohn\b$(?!-[A-z])/m
str = 'John Doe
John-Doe
Doe John
Doe-John
John
Doe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end