use strict;
my $str = 'ABC123 08-10 Caterpillar
But not this:
ABC123 fits 08-10 Caterpillar
or this:
ABC123 for 08-10 Caterpillar XYZ789';
my $regex = qr/^(((?!fits).)*((\d{2}-\d{2}\s)Caterpillar))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}