$re = '/^(((?!fits).)*((\d{2}-\d{2}\s)Caterpillar))$/m';
$str = 'ABC123 08-10 Caterpillar
But not this:
ABC123 fits 08-10 Caterpillar
or this:
ABC123 for 08-10 Caterpillar XYZ789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);