import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(http|https):\\/\\/(www\\.)[a-zA-Z0-9-.]+\\.[a-zA-Z]{2,3}(:[a-zA-Z0-9])?\\/?([a-zA-Z0-9-._\\?\\,\\'\\/\\+&%\\$#\\=~]+)*$";
final String string = "http://www.test.com\n"
+ "https://www.test.com/login";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}