re = /^(http|https):\/\/(www\.)[a-zA-Z0-9-.]+\.[a-zA-Z]{2,3}(:[a-zA-Z0-9])?\/?([a-zA-Z0-9-._\?\,\'\/\+&%\$#\=~]+)*$/m
str = 'http://www.test.com
https://www.test.com/login'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end