package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\\.`)
var str = `rsync -r -t -p -o -g -v --progress --delete -l -H /Users/ken/Library/Application\ Support/Sublime\ Text\ 3/Packages /Users/ken/Google\ Drive/__config-GD/ST3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}