$re = '/\\\\./';
$str = 'rsync -r -t -p -o -g -v --progress --delete -l -H /Users/ken/Library/Application\\ Support/Sublime\\ Text\\ 3/Packages /Users/ken/Google\\ Drive/__config-GD/ST3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);