using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ep.*[0-9]";
string input = @"Ep.1: The Womanizer";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}