$re = '/ep.*[0-9]/i';
$str = 'Ep.1: The Womanizer';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);