use strict;
my $str = '\\nHi Take ! \\n\\nThank you for welcome me for the stay. \\nI regretted to informed you i can only make a reservation around 7hours later as my husband is currently working .\\nSo, if i book this what is the earliest time i can check in ?\\nHow do i contact when i reach Japan ? \\n\\n\\n1. このメールから直接Everleneさんに返信する\\n2. またはオンラインでEverleneさんに返信する:\\nhttps://www.airbnb.jp/z/q/178989336?eluid=0&euid=fbdfea3f-6ac3-edae-ab50-3b3eae5e9f50\\n\\n------------------------------------------------------------------------\\nリスティング「西新宿駅1分!」を見る:\\nhttps://www.airbnb.jp/rooms/9602551?eluid=1&euid=fbdfea3f-6ac3-edae-ab50-3b3eae5e9f50\\n\\nAirbnbのホストへのメッセージを確認・送る方法:\\nhttps://www.airbnb.jp/help/question/145?eluid=2&euid=fbdfea3f-6ac3-edae-ab50-3b3eae5e9f50\\n\\nAirbnbのヘルプセンターの役立つ情報をご覧ください:\\nhttps://www.airbnb.jp/help?eluid=3&euid=fbdfea3f-6ac3-edae-ab50-3b3eae5e9f50\\n------------------------------------------------------------------------\\n\\nメール配信設定\\nhttps://www.airbnb.jp/users/notifications?eluid=4&euid=fbdfea3f-6ac3-edae-ab50-3b3eae5e9f50\\n\\n### Airbnb ###\\n';
my $regex = qr/\s{1,2}1. 直接回复此邮件以回复.+\s{1,2}2. 或在线回复/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}