// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s{1,2}1. 直接回复此邮件以回复.+\s{1,2}2. 或在线回复").unwrap();
let string = "\\nHi Take ! \\n\\nThank you for welcome me for the stay. \\nI regretted to informed you i can only make a reservation around 7hours later as my husband is currently working .\\nSo, if i book this what is the earliest time i can check in ?\\nHow do i contact when i reach Japan ? \\n\\n\\n1. このメールから直接Everleneさんに返信する\\n2. またはオンラインでEverleneさんに返信する:\\nhttps://www.airbnb.jp/z/q/178989336?eluid=0&euid=fbdfea3f-6ac3-edae-ab50-3b3eae5e9f50\\n\\n------------------------------------------------------------------------\\nリスティング「西新宿駅1分!」を見る:\\nhttps://www.airbnb.jp/rooms/9602551?eluid=1&euid=fbdfea3f-6ac3-edae-ab50-3b3eae5e9f50\\n\\nAirbnbのホストへのメッセージを確認・送る方法:\\nhttps://www.airbnb.jp/help/question/145?eluid=2&euid=fbdfea3f-6ac3-edae-ab50-3b3eae5e9f50\\n\\nAirbnbのヘルプセンターの役立つ情報をご覧ください:\\nhttps://www.airbnb.jp/help?eluid=3&euid=fbdfea3f-6ac3-edae-ab50-3b3eae5e9f50\\n------------------------------------------------------------------------\\n\\nメール配信設定\\nhttps://www.airbnb.jp/users/notifications?eluid=4&euid=fbdfea3f-6ac3-edae-ab50-3b3eae5e9f50\\n\\n### Airbnb ###\\n";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}