const regex = /\d+\/\d+\/\d+\s(\d+:\d+:\d+\s(AM|PM))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\\/\\d+\\\/\\d+\\s(\\d+:\\d+:\\d+\\s(AM|PM))', '')
const str = `7/25/2015 5:45:40 AM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}