import Foundation
let pattern = #"\d+\/\d+\/\d+\s(\d+:\d+:\d+\s(AM|PM))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"7/25/2015 5:45:40 AM"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}