#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]+,\s(?:[A-Z]\.)+[A-Z]?$"
Local $sString = "Bank, A." & @CRLF & _
"Bank, A.B." & @CRLF & _
"Bank, A.B.C." & @CRLF & _
"Bank, A.B.C.D." & @CRLF & _
"BANK, A." & @CRLF & _
"BANK, A.B"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")