package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]+,\s(?:[A-Z]\.)+[A-Z]?$`)
var str = `Bank, A.
Bank, A.B.
Bank, A.B.C.
Bank, A.B.C.D.
BANK, A.
BANK, A.B`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}