using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d{2}([-.])\d{3}\1\d{3}\1\d{3}|\d{11})$";
string input = @"46123456789
46-123-456-789
46-123-456-789
+46-123-456-789
+46123456789
46-123-456.789
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}