re = /^(?:\d{2}([-.])\d{3}\1\d{3}\1\d{3}|\d{11})$/m
str = '46123456789
46-123-456-789
46-123-456-789
+46-123-456-789
+46123456789
46-123-456.789
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end