using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\?([а-яёa-z0-9_]{0,100})";
string input = @"http://мой-адрес.рф/?чтото&what=whatsuuuuup-man!!!";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}