$re = '/\?([а-яёa-z0-9_]{0,100})/iu';
$str = 'http://мой-адрес.рф/?чтото&what=whatsuuuuup-man!!!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);