package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([[:digit:]]{3}\.?){3}(\-|\.)[[:digit:]]{2}$`)
var str = `821.446.257-15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}