$re = '/(http[s]?:\/\/)?([^\/\s]+\/)(.*)/';
$str = 'https://www.mysite.com/en/myslug/
https://www.subdomain.mysite.com/en/myslug/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);