re = /(http[s]?:\/\/)?([^\/\s]+\/)(.*)/
str = 'https://www.mysite.com/en/myslug/
https://www.subdomain.mysite.com/en/myslug/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end