package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\D\d)+)(.{3})((\D(\d|\D)){2})`)
var str = `R2D2BB8C3PO`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}