$re = '/((\D\d)+)(.{3})((\D(\d|\D)){2})/';
$str = 'R2D2BB8C3PO';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);