package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((?:[^()]*\([^()]*\))*[^()]*\)\.`)
var str = `some text (some text) some (text (text) some).
some text (some text) some (text).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}