re = /\((?:[^()]*\([^()]*\))*[^()]*\)\./m
str = 'some text (some text) some (text (text) some).
some text (some text) some (text).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end