const regex = /^(.*)\s(.*)\s(\[.*\])\s(\/.*\/)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)\\s(.*)\\s(\\[.*\\])\\s(\\\/.*\\\/)', '')
const str = `AB制 AB制 [A B zhi4] /to split the bill (where the male counterpart foots the larger portion of the sum)/(theater) a system where two actors take turns in acting the main role, with one actor replacing the other if either is unavailable/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}