re = /^(.*)\s(.*)\s(\[.*\])\s(\/.*\/)/
str = 'AB制 AB制 [A B zhi4] /to split the bill (where the male counterpart foots the larger portion of the sum)/(theater) a system where two actors take turns in acting the main role, with one actor replacing the other if either is unavailable/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end