package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)data-rlocation=\"([^\"]*)\"`)
var str = `<p class="sm clg" data-rlocation="Uttam Nagar East">Uttam Nagar East, Delhi <span class="to-txt" id="citytt1">B-24, East Uttam Nagar, Uttam Nagar East,<br>Delhi<span> - </span>110059`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}