// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)data-rlocation=\"([^\"]*)\""#).unwrap();
let string = "<p class=\"sm clg\" data-rlocation=\"Uttam Nagar East\">Uttam Nagar East, Delhi <span class=\"to-txt\" id=\"citytt1\">B-24, East Uttam Nagar, Uttam Nagar East,<br>Delhi<span> - </span>110059";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}