using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^images/(?:(?P<prefix>\w+)/)?(?P<uuid4>[0-9a-f]{8}(?:-[0-9a-f]{4}){3}-[0-9a-f]{12})\.(?P<ext>\w+)";
string input = @"images/05a813eb-df00-4ed6-b8a5-2930f03fbf5d.jpg
images/img/05a813eb-df00-4ed6-b8a5-2930f03fbf5d.jpg";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}