re = /^images\/(?:(?P<prefix>\w+)\/)?(?P<uuid4>[0-9a-f]{8}(?:-[0-9a-f]{4}){3}-[0-9a-f]{12})\.(?P<ext>\w+)/im
str = 'images/05a813eb-df00-4ed6-b8a5-2930f03fbf5d.jpg
images/img/05a813eb-df00-4ed6-b8a5-2930f03fbf5d.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end